[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4762: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4764: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4765: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4766: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3897)
PowerWorship Forums • View topic - enviroment error in pw4 (Office 2016)

enviroment error in pw4 (Office 2016)

Get help for techical problems or report a bug

enviroment error in pw4 (Office 2016)

Postby techidave » Sun Jan 08, 2017 8:02 am

I have both LibreOffice 5.1 and MS Office 2016 installed on my computer. I got the error (see attached) when I went into Environment and changed it from Impress to PowerPoint.

A problem with Office 2016?
Attachments
Screenshot (1).png
Screenshot (1).png (608.2 KiB) Viewed 2248 times
techidave
Site Admin
 
Posts: 115
Joined: Thu Nov 06, 2008 10:49 am
Location: Kansas

Re: enviroment error in pw4

Postby JohnM » Thu Jan 19, 2017 7:04 pm

Likely a pW support issue with Office/PowerPoint 2016; yeah. PowerWorship not yet been tested yet, with Office 2016-- to my knowledge. The API being used to open templates may no longer be supported in Office 2016. Based on the error message-- it appears that things are failing when trying to load a specific template (Black.pot) which is then used in the settings to show what the current template selection is (when PowerPoint is selected as the active Presentation software to use).

Others please reply if you are successfully using PowerWorship with Office 2016. Unless it's an environment issue, specific to the machine where you are getting the error (which is possible, although probably not likely) then I suspect others will see the same error with PowerPoint 2016.

If you get a chance to try it-- what happens if you try to open the template referenced in the error message. i.e. open Black.pot by itself in PowerPoint? Can you open it? The template is located at %ProgramData%\PowerWorship\pW4, which is typically at C:\ProgramData\PowerWorship\pW4 on most installations of Windows; depending which drive letter is assigned to your Windows partition.

If you can't find it (i.e. the template to attempt to open) you can enter %ProgramData%\PowerWorship\pW4 into the address bar in Windows Explorer (now called File Explorer) and it should resolve OK. i.e. the %ProgramData% environment variable should resolve to the correct root directory. It might be that in Office 2016-- Microsoft removed support for .pot templates (in favor of .potx) , but I haven't looked into this-- and so I'm not sure if that's the case. If you can open the template itself-- that would help provide an indication-- one way or the other.

Capture.PNG
Capture.PNG (20.19 KiB) Viewed 2232 times
JohnM
Site Admin
 
Posts: 283
Joined: Sun Mar 14, 2004 7:16 am

Re: enviroment error in pw4

Postby JohnM » Thu Jan 19, 2017 7:14 pm

If the .pot files can't be opened in PowerPoint 2016, a work around (for now) would be to save and use a set of templates as .potx files, while deleting the existing .pot files from the templates directory (after saving them as .potx and/or after optionally backing them up).
JohnM
Site Admin
 
Posts: 283
Joined: Sun Mar 14, 2004 7:16 am

Re: enviroment error in pw4 (Office 2016)

Postby techidave » Thu Jan 19, 2017 8:30 pm

I will give your suggestions a try this weekend and report back.
techidave
Site Admin
 
Posts: 115
Joined: Thu Nov 06, 2008 10:49 am
Location: Kansas

Re: enviroment error in pw4 (Office 2016)

Postby techidave » Sun Jan 22, 2017 5:18 am

Believe I found the problelm. I only had certain parts of MS Office installed and PPT was not one of them. But I did have all of LibreOffice installed. Once I installed PPT, pw4 worked as it should.
dave
techidave
Site Admin
 
Posts: 115
Joined: Thu Nov 06, 2008 10:49 am
Location: Kansas

Re: enviroment error in pw4 (Office 2016)

Postby JohnM » Mon Jan 23, 2017 7:48 pm

Good to hear, thanks; the error messages from MS Office and .NET, etc. are not always the most helpful [1] similar to error messages in general for most (or perhaps all) software on the market, both commercial and open source, etc. i.e. the error messages are not always as good as they could be. Glad u were able to find the problem and get past it.

[1] and pW does not validate whether PowerPoint is installed during pW installation or execution, even though it perhaps should -- during execution of certain operations that require PPT.
JohnM
Site Admin
 
Posts: 283
Joined: Sun Mar 14, 2004 7:16 am


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 1 guest