Microsoft .NET Framework 3.5 (or later) error

Get help for techical problems or report a bug
Post Reply
Beforr
Newcomer
Posts: 1
Joined: Thu Jan 09, 2014 5:09 pm

Microsoft .NET Framework 3.5 (or later) error

Post by Beforr » Thu Jan 09, 2014 5:19 pm

HI guys- I'm trying to get started with Power Worship and ran into a "Microsoft .NET Framework 3.5 (or later) is not installed" error. I know the installation instructions tell you to install the Framework software and then attempt reinstall of PW, but my computer already has Microsoft .NET Framework 4.5.1 installed as of last month so it should be good to go. I'm running Windows 7. Could the PW software not be recognizing that update somehow?

Thanks for your help!
Bob

JohnM
Site Admin
Posts: 283
Joined: Sun Mar 14, 2004 7:16 am
Contact:

Re: Microsoft .NET Framework 3.5 (or later) error

Post by JohnM » Fri Jan 10, 2014 1:00 am

This is a type-O in the installation instructions and in the installation program error message. Both have now been updated to reflect that the .NET Framework 3.5 (specifically) is required for PowerWorship 4.0.

Please note, this is a current limitation that will be removed in a future pW service release, when support for the .NET Framework 4.x is available. Please also note that you can enable the .NET Framework 3.5 (or install it in the case of Windows XP) and it can coexist just fine with the .NET Framework 4.x.

Please see the following (newly updated) instructions for information on how to enable the .NET Framework 3.5 in Windows 7, which is relatively quick via the Control Panel > Programs > Turn windows features on or off.

viewtopic.php?f=5&t=586

If you get a chance to try this out, please confirm that this solves the issue and let us know if you have any further questions.

Thanks!
John

JohnM
Site Admin
Posts: 283
Joined: Sun Mar 14, 2004 7:16 am
Contact:

Re: Microsoft .NET Framework 3.5 (or later) error

Post by JohnM » Thu Jan 23, 2014 12:20 am

Update: PowerWorship has been updated (as of version 4.0.1) to run on the .NET Framework 4.0.

Version 3.5 of .NET Framework is no longer required, but version 4.0 is the new requirement.

The PowerWorship 4.0 installation wizard will now check for version 4.0 of the .NET Framework and will abort the installation if version 4.0 is missing, and it will prompt you with instructions for installing version 4.0, if necessary.

Post Reply