Creating a new collection problem

Get help for techical problems or report a bug
techidave
Site Admin
Posts: 115
Joined: Thu Nov 06, 2008 10:49 am
Location: Kansas

Creating a new collection problem

Post by techidave » Sat Feb 28, 2015 5:52 am

I had some difficulty creating a new collection and then trying to add songs to it. When naming a new collection I didn't know if it took the name. I tried hitting enter but all I got was a ding. However when I would go to the collections tab, it was there.
Then i tried adding a song to the collection by right clicking a song and choosing add to collection. then I got the message that I needed to open or create a collection before adding a song.

I cannot for the life of me figure this out.
Attachments
pw_collection_problem.zip
(165.85 KiB) Downloaded 295 times

JohnM
Site Admin
Posts: 283
Joined: Sun Mar 14, 2004 7:16 am
Contact:

Re: Creating a new collection problem

Post by JohnM » Sat Feb 28, 2015 7:27 am

Re: saving/taking the collection name. You need to perform an explicit save (File > Save) or use Ctrl + S as a shortcut. Or if you try to close the collection or exit PowerWorship without saving, you will then be prompted to Save any draft songs/collections.

For the other issue - adding songs to a collection, it sounds like you might not have the collection selected (and visible, on the right hand side) when you are attempting to add the song to the collection. If you have a song selected/and visible on the right, or if you otherwise do not have a collection open and visible - you will get the message you are seeing.

For the 2nd issue (add song to collection) that area needs some work from a usability perspective to make it more intuitive.

techidave
Site Admin
Posts: 115
Joined: Thu Nov 06, 2008 10:49 am
Location: Kansas

Re: Creating a new collection problem

Post by techidave » Sun Mar 01, 2015 2:10 pm

is it possible to add a submit button or allow enter to be used when inputting a name for a collection? While Crtl + S or Save works, adding the above might make it more user friendly :P

techidave
Site Admin
Posts: 115
Joined: Thu Nov 06, 2008 10:49 am
Location: Kansas

Re: Creating a new collection problem

Post by techidave » Sun Mar 01, 2015 2:36 pm

I am still struggling with the whole songs/ collection thing. I have been able to add a new collection but am unable to see the song list after that.

see attached file.

Thanks John for your hard work to make this program better.
Attachments
collection_problem.zip
(68.12 KiB) Downloaded 296 times

techidave
Site Admin
Posts: 115
Joined: Thu Nov 06, 2008 10:49 am
Location: Kansas

Re: Creating a new collection problem

Post by techidave » Sun Mar 01, 2015 4:01 pm

my bad. I didn't have any songs in the free version. once imported some then it works as expected. :oops: :oops:

JohnM
Site Admin
Posts: 283
Joined: Sun Mar 14, 2004 7:16 am
Contact:

Re: Creating a new collection problem

Post by JohnM » Mon Mar 02, 2015 8:06 pm

Hi Dave,

Re: the missing submit, etc. button on the Collection page - I've tried to simplify the form and keep the page design as clean as possible. But I can see where a submit button on the page would be more immediately obvious and intuitive. Appreciate the feedback, and I'll consider it. Worth noting that Google Chrome and MS Office, etc. take a similar design approach though - and try to avoid too much redundancy in menu options, etc. This admittedly comes at the expense of programs being harder to learn the first time, but once you are familiar - it can be better/cleaner, etc. in the long run with screens that are less cluttered, etc. Definitely a trade off though.

Please note that for a button to click - without having to use Ctrl + S, or File > Save, if you click the disk/Save icon which is always visible at the top left (similar to MS Word, and other programs) and this will have the save effect as a 'submit' button, if added, with the added benefit that it (the existing 'Save' button) works for Songs as well as Collections.

Thanks much,
John

techidave
Site Admin
Posts: 115
Joined: Thu Nov 06, 2008 10:49 am
Location: Kansas

Re: Creating a new collection problem

Post by techidave » Sun Jan 22, 2017 5:53 am

still having problems in this area. I made a new collection, added a couple of songs to it and then hit the create slides. I get the following error message, see attachment.
Am I the only one who struggles with pw4? :?
Attachments
create slides problem in pw4.PNG
create slides problem in pw4.PNG (47.97 KiB) Viewed 4486 times

techidave
Site Admin
Posts: 115
Joined: Thu Nov 06, 2008 10:49 am
Location: Kansas

Re: Creating a new collection problem

Post by techidave » Sun Jan 22, 2017 6:06 am

I finally got it to open a ppt presentation but it was empty. see attached. its almost like it didn't save the 2 songs i had placed in the collection. thought I had save after that.
nopresentation.PNG
nopresentation.PNG (31.61 KiB) Viewed 4486 times

techidave
Site Admin
Posts: 115
Joined: Thu Nov 06, 2008 10:49 am
Location: Kansas

Re: Creating a new collection problem

Post by techidave » Sun Jan 22, 2017 6:15 am

i see the "preparing slides for collection: jan 22 2017..." at the bottom of the window, but it doesn't appear to finish.

If I go ahead and click create slides, then I get the error message about no collection selected. I guess I thought I knew how to do this.

I see now. I have to "right click" the song to add it to the selected collection. But when I go to create the slides, the default background is "black" thus the default font color is also "black", so the slides appear to be empty.

Once I realized the problem and edited those settings, it worked well. maybe default settings should be changed to something that will be visible?

dave
Attachments
preparingslides for collection.PNG
preparingslides for collection.PNG (48.51 KiB) Viewed 4486 times

techidave
Site Admin
Posts: 115
Joined: Thu Nov 06, 2008 10:49 am
Location: Kansas

Re: Creating a new collection problem

Post by techidave » Sun Jan 22, 2017 6:25 am

it appears that everything is done with the right click in pw4 now.

It would appear to me if the collection is selected, when going to the "songs" tab, I should be able to double click another song and it will add it to the collection. right now, that is not the case.

I have been reading the help file to try and figure out the way the program works. After going through all of the problems, looking through the help file is of upmost importance.

Hopefully others will chime in if they are having the same problems using the program for the first time.

JohnM
Site Admin
Posts: 283
Joined: Sun Mar 14, 2004 7:16 am
Contact:

Re: Creating a new collection problem

Post by JohnM » Mon Jan 23, 2017 8:08 pm

techidave wrote:still having problems in this area. I made a new collection, added a couple of songs to it and then hit the create slides. I get the following error message, see attachment.
Am I the only one who struggles with pw4? :?
For the "no collection selected" error/issue, it appears in the screenshot you have a song selected (on the right hand side) instead of a collection. Selecting a collection in the navigation won't do the trick, although it perhaps should. Will note that as a potential usability issue/concern.

JohnM
Site Admin
Posts: 283
Joined: Sun Mar 14, 2004 7:16 am
Contact:

Re: Creating a new collection problem

Post by JohnM » Mon Jan 23, 2017 8:12 pm

techidave wrote:I finally got it to open a ppt presentation but it was empty. see attached. its almost like it didn't save the 2 songs i had placed in the collection. thought I had save after that.
nopresentation.PNG
In the screenshot, it appears there are no songs in the collection. Need to right-click them and add to collection, yeah. From a usability perspective, there could be more ways of adding songs to a collection (E.g. keyboard shortcuts, etc.) especially to avoid using the mouse-- but the interface is relatively simple/basic for 4.0.

JohnM
Site Admin
Posts: 283
Joined: Sun Mar 14, 2004 7:16 am
Contact:

Re: Creating a new collection problem

Post by JohnM » Mon Jan 23, 2017 8:15 pm

techidave wrote:i see the "preparing slides for collection: jan 22 2017..." at the bottom of the window, but it doesn't appear to finish.

If I go ahead and click create slides, then I get the error message about no collection selected. I guess I thought I knew how to do this.

I see now. I have to "right click" the song to add it to the selected collection. But when I go to create the slides, the default background is "black" thus the default font color is also "black", so the slides appear to be empty.

Once I realized the problem and edited those settings, it worked well. maybe default settings should be changed to something that will be visible?

dave
The actual default [background/font color] should be a white background with Black text. Is it possible the background was changed to Black, in the user settings-- since you originally installed pW? If not-- then I have no explanation :? In any event, plenty of possible usability improvements in this area. Appreciate the feedback and trying things out.

JohnM
Site Admin
Posts: 283
Joined: Sun Mar 14, 2004 7:16 am
Contact:

Re: Creating a new collection problem

Post by JohnM » Mon Jan 23, 2017 8:18 pm

techidave wrote:it appears that everything is done with the right click in pw4 now.

It would appear to me if the collection is selected, when going to the "songs" tab, I should be able to double click another song and it will add it to the collection. right now, that is not the case.

I have been reading the help file to try and figure out the way the program works. After going through all of the problems, looking through the help file is of upmost importance.

Hopefully others will chime in if they are having the same problems using the program for the first time.
Double-click a song opens the song vs. adding to the selected collection, but ideally the operations should be configurable-- for better usability. Especially if folks are coming from pW 3.x where they were accustomed to double click being used to add songs to a collection/group. Again, thanks for the great feedback/suggestions.

techidave
Site Admin
Posts: 115
Joined: Thu Nov 06, 2008 10:49 am
Location: Kansas

Re: Creating a new collection problem

Post by techidave » Mon Jan 23, 2017 8:23 pm

I will install pw 4 on a different computer to see what the default font color/background is.

let you know later.

Post Reply